• 欢迎访问阿黑哥的博客,分享新老技术及精品软件
  • 技术不断,生命不息,折腾不止
  • 推荐使用Chrome浏览器访问本网站
  • 由于之前把部分图片存于七牛云,而没有绑定域名导致图片无法加载。现已部分修复
  • 如果您觉得本博客非常有趣,那就赶紧使用Ctrl+D 收藏本站吧
  • CloudCone VPS双十一超级特价,限量折扣,最低$14.11/年

ROS指定域名走专线解析

网络技术 aheig 5个月前 (08-07) 288次浏览 0个评论
文章目录[隐藏]

前言

前面我们讲了多个运营商线路同时接入使用不同 DNS 线路上网:RouterOS 的 DNS 分流
这里讲另一种蛋疼的情况。你有两条出口。一条带宽充足,但速度较慢;另一条速度极快,但带宽较低(或者可以无阻碍上网,但带宽不够)。而有些网站实际并没有被 Q,仅仅只是 DNS 污染。此时我们可以使用 DNS 解析与访问站点分流的办法解决。

步骤

首先,添加七层协议组 domain
把下面的域名换成你要分流解析的域名
注意格式:最后一条域名后面没有分隔符

/ip firewall layer7-protocol
add name=domain regexp="facebook.com|youtube.com|googledrive.com|googleearh.com|googlehosted.com|googlelabs.com|googlemail.com|googlepages.com|googleplus.com|googlesile.com|googlesource.com|googlesyndication.com|googletagmanager.com|googletagservices.com|googleusercontent.com|googlevideo.com|gstatic.com|gvt1.com|hbo.com|hbogo.com|amazon.co.jp"

添加标记路由
例如,我要指定的出口是 gre-tunnel1 隧道

/ip route
add distance=3 gateway=gre-tunnel1 routing-mark=GW_DNS

域名解析重定向
例如,我这里将七层协议里的 domain 解析重定向到 1.1.1.1 服务器

/ip firewall nat
add action=dst-nat chain=dstnat dst-port=53 layer7-protocol=domain protocol=udp to-addresses=1.1.1.1 to-ports=53
add action=dst-nat chain=dstnat dst-port=53 layer7-protocol=domain protocol=tcp to-addresses=1.1.1.1 to-ports=53

最后,通过路由标签指定访问 1.1.1.1 的路由

/ip firewall mangle
add action=mark-routing chain=prerouting layer7-protocol=domain new-routing-mark=GW_DNS passthrough=yes place-before=0

调好以上配置就可以给 domain 里的域名使用隧道去解析了。ROS 玩法实在太多。我也只是小白一枚。期待更多高手萌新前来一起交流


阿黑哥博客 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:ROS 指定域名走专线解析
喜欢 (1)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址